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Contacting Support

Main Site

arubanetworks.com

Support Site

asp.arubanetworks.com

Airheads Social Forums and Knowledge Base

community.arubanetworks.com

North American Telephone

1-800-943-4526 (Toll Free)
1-408-754-1200

International Telephone

arubanetworks.com/support-services/contact-support/

Software Licensing Site

Ims.arubanetworks.com

End-of-life Information

arubanetworks.com/support-services/end-of-life/

Security Incident Response Team (SIRT)

Site: arubanetworks.com/support-services/security-bulletins/

Email: aruba-sirt@hpe.com
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Chapter 1
Overview

This document provides best practices for leveraging AirWave to monitor and manage your Aruba infrastructure,
which provides a wealth of functionality such as firewall, VPN, remote AP, IDS, IPS, and ARM, as well as an
abundance of statistical information.

Follow the simple guidelines in this document to garner the full benefit of your Aruba infrastructure.
This overview chapter contains the following topics:

e "Understanding Aruba Topology" on page 6

e '"Prerequisites for Integrating Aruba Infrastructure " on page 6

Understanding Aruba Topology
Figure 1 depicts a typical master-local deployment for the AirWave Wireless Management System (AWMS):
Figure 1: Typical Aruba Deployment

-~ Component Without AWMS With AWMS
o AWMS AWMS communicates directly
ﬁ:a with local and master controllers

to gather and correlate statistics

y
Master Controller | Correlates all state Functions as a local controller
information from all

iy downstream access points
I";E-Eéﬁcl l'_ég_r_'l Local Controllers | Collect downstream AP Collect downstream AP statistical
F1 1 ;_; ] statistical information and state information
o \ , \ m - " - 2
| |I \ fl o “. Thin APs Send all state information | Send all state information to local
b ) 4o to the master controller controller
vy \vyvy

= =

| d There should never be a local controller managed by an AirWave server whose master controller is also not
under management.

Prerequisites for Integrating Aruba Infrastructure
In order to integrate your Aruba infrastructure, you need the following information:
e SNMP community string for monitoring and discovery

o Telnet/SSH credentials for configuration

o Enable password for configuration
e SNMPv3 credentials for WMS offload

| d Without proper Telnet/SSH credentials, AirWave will not be able to acquire license, serial information, and
monitoring schema from controllers.
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Chapter 2
Configuring AirWave for Global Aruba

Infrastructure

This section explains how to configure AirWave to globally manage your Aruba infrastructure.
e "Disabling Rate Limiting in AMP Setup > General" on page 8

e "Entering Credentials in Device Setup > Communication" on page 8

e "Setting Up Recommended Timeout and Retries" on page 10

e "Setting Up Time Synchronization" on page 10

e "Enabling Support for Channel Utilization And Statistics" on page 11

Disabling Rate Limiting in AMP Setup > General

The SNMP Rate Limiting for Monitored Devices option adds a small delay between each SNMP GET request,
which results in the actual polling intervals that are longer than what is configured. For example, setting a ten-
minute polling interval will result in an actual 12-minute polling interval. Disabling rate limiting is recommended
in most cases unless you are using legacy Aruba devices, such as M2 devices.

To disable rate limiting in AirWave, follow these steps:
Navigate to AMP Setup > General.
Locate the Performance section.

Inthe SNMP Rate Limiting for Monitored Devices field, select No, as shown in Figure 2.
Click Save.

AwnN =

Figure 2: SNMP Rate Limiting in AMP Setup > General > Performance

Performance

Monitoring Processes (1-64):
Maximum number of configuration processes (1-80):

Maximum number of audit processes (1-80):

[N VYRI5 B V]

SNMP Fetcher Count (2-6):

Verbose logging of SNMP configuration: © Yes @ No

SNMP rate limiting for monitored devices: © Yes @ No

Client Association Relevance Factor (0-550 days, zero disables): 0
RAPIDS Processing Priority:

When AMP is processing data at or near its maximum capacity, reducing the
priority of RAPIDS can ensure that processing of other data (e.g. client connections
and bandwidth) is not adversely impacted. Low ~

The default priority is Low. You can also tune your system performance by
changing group poll periods.

Entering Credentials in Device Setup > Communication

AirWave requires several credentials to properly interface with Aruba devices. To enter these credentials, follow
these steps:

1. Navigate to Device Setup > Communication.

2. Inthe Default Credentials section, select the Edit link next to Aruba. The page illustrated in Figure 3
appears.
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3. Enter the SNMP Community String.

| d Be sure to note the community string because it must match the SNMP trap community string, which is

configured later in this document.

Figure 3: Credentials in Device Setup > Communication

IHHHIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIIII

Community String:

Confirm Community String:
Telnet/SSH Username:
Telnet/SSH Password:
Confirm Telnet/SSH Password:
"enable" Password:

Confirm "enable" Password:
SNMPv3 Username:

Auth Password:

Confirm Auth Password:
SNMPv3 Auth Protocol:
Privacy Password:

Confirm Privacy Password:

SNMPvV3 Privacy Protocol:

4. Enter the required information for configuration and basic monitoring:

e Telnet/SSH user name
e Telnet/SSH password
e Enable mode password

5. Enter the required data for WMS Offload:

e SNMPv3 user name
e Authentication password

e SNMPv3 authentication protocol (must be SHA-1)

e Privacy password

e SNMPv3 privacy protocol (must be DES)

admin

SHA-1

DES

E The authentication and privacy protocols must be SHA-1 and DES for WMS Offload to work correctly.

NOTE

6. Click Save.
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1. Inthe Device Setup > Communication page, locate the SNMP Setting section.

2. Change the SNMP Timeout setting to a value or either 3, 4, or 5. This is the number of seconds that AirWave
will wait for a response from a device after sending an SNMP request, so a smaller number is more ideal.

3. Change the SNMP Retries value to 10. This value represents the number of times AirWave tries to poll a
device when it does not receive a response within the SNMP Timeout Period or the Group's Missed SNMP Poll
Threshold setting (1-100).

Although the upper limit for this value is 40, some SNMP libraries still have a hard limit of 20 retries. In these
cases, any retry value that is set above 20 will still stop at 20.

NOTE
Figure 4: Timeout settings in Device Setup > Communication
SNMP Timeout (3-60 sec): 3
SNMP Retries (1-40):
4. Click Save when you are done.
You can set the clock on a controller manually or by configuring the controller to use a Network Time Protocol
(NTP) server to synchronize its system clock with a central time source.
Manually Setting the Clock on a Controller
You can use either the WebUI or CLI to manually set the time on the controller's clock.
1. Navigate to the Configuration > Management > Clock page.
2. Under Controller Date/Time, set the date and time for the clock.
3. Under Time Zone, enter the name of the time zone and the offset from Greenwich Mean Time (GMT).
4. To adjust the clock for daylight savings time, click Enabled under Summer Time. Additional fields appear that
allow you to set the offset from UTC and the start and end recurrences.
5. Click Apply.
Setting Up NTP
Onthe AMP Setup > Network page, locate the Network Time Protocol (NTP) section. The Network Time
Protocol is used to synchronize the time between AirWave and your network reference NTP server. NTP servers
synchronize with external reference time sources, such as satellites, radios, or modems.
Specifying NTP servers is optional. NTP servers synchronize the time on the AirWave server, not on individual
NoT access points.

To disable NTP services, clear both the Primary and Secondary NTP server fields. Any problem related to
communication between AirWave and the NTP servers creates an entry in the event log. For more information
on ensuring that AirWave servers have the correct time, please see
http://support.ntp.org/bin/view/Servers/NTPPoolServers.

AirWave 8.2.11.1 | Best Practices Guide
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Table 1: AMP Setup> Network > Secondary Network Fields and Default Values
Setting Default Description

Primary ntp1.yourdomain.com | Sets the IP address or DNS name for the primary NTP server.

Secondary | ntp2.yourdomain.com | Sets the IP address or DNS name for the secondary NTP server.

Enabling Support for Channel Utilization And Statistics

To enable support for channel utilization statistics, your AirWave server and ArubaOS and Aruba Instant devices
must be running the following versions of software:

o AirWave 7.6 or later
o Aruba0S6.0.1 or later
o Arubalnstant 3.3 or later

Devices running Aruba0S 6.0.1 can report RF utilization metrics, but ArubaOS 6.1 or later is necessary to also
obtain classified interferer information.

AirWave Setup

1. Navigate to AMP Setup > General.

2. Inthe Additional AMP Services section, set Enable AMON Data Collection to Yes, and set Prefer
AMON vs SNMP Polling to Yes.

3. Click Save.
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CAUTION

Figure 5: AMON Data Collection Setting in AMP Setup > General

Additional AMP Services

Enable FTP server: ) )
required to manage Aruba AirMesh & Cisco 4800 APs; optional for firmware upgrades on @ Yes ) No
supported devices.

Enable RTLS collector:

Aruba only 0 Yes @ No
Use Embedded Mail Server: @ Yes @ No
Mail Relay Server: optional

Process user roaming traps from Cisco WLC: @ Yes © No
Enable AMON Data Collection: @ Yes @ No

Enable Clarity Data Collection:

@ &
Requires AOS version 6.4.3 and above ® Yes © No

Enable AppRF Data Collection: @ Yes © No
AppRF Storage Allocated (GiB): 25

Greater than or equal to 2 GiB
Enable UCC Data Collection:

@ )
Requires ADS version 6.4 and above 3 Yes O No

Enable UCC Calls Stitching (Heuristics): @ Yes @ No
Prefer AMON vs SNMP Polling: @ Yes © No
Enable Syslog and SNMP Trap Collection: @ Yes @ No
Require S5H host key verification: © Yes @ No

Controller Setup (Master And Local)

Enabling these commands on ArubaOS versions prior to 6.0.1.0 can result in performance issues on the controller. If
you are running previous firmware versions such as ArubaOS 6.0.0.0, you should upgrade to ArubaOS 6.0.1 (to obtain
RF utilization metrics) or 6.1 (to obtain RF utilization and classified interferer information) before you enter this
command.

Using ArubaOS 6.x

The following commands are for ArubaOS versions 6.3.1 and later 6.x releases. To get the commands for other
versions of ArubaOS 6.x, refer to the Command-Line Interface Reference Guide for that version.

Use SSH to access the controller's command-line interface, enter enable mode, and issue the following
commands:

(Controller-Name) # configure terminal

Enter Configuration commands, one per line. End with CNTL/Z
(Controller-Name) (config) # mgmt-server type amp primary-server <AMP-IP>
(Controller-Name) (config) # mgmt-server profile <profile-name>
(Controller-Name) (config) # write mem

Using ArubaOS 8.x

The following commands are for ArubaOS versions 8.4 and earlier 8.x releases. To get the commands for other
versions of ArubaOS 8.x, refer to the Command-Line Interface Reference Guide for that version.

Use SSH to access Mobility Master's command-line interface, enter enable mode, and issue the following
commands:

(host) [mynode] # configure terminal

AirWave 8.2.11.1 | Best Practices Guide
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Enter Configuration commands, one per line. End with CNTL/Z
(host) [mynode] (config) #mgmt-server primary-server <AMP-IP>
(host) [mynode] (config) #profile default-amp

(host) [mynode] (config) #write memory

You can add up to four <AMP-IP> addresses.

HOTE
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Chapter 3
Configuring an Aruba Group

It is prudent to establish one or more Aruba Groups within AirWave. During the discovery process you will move
new discovered controllers into this group.

This section contains the following topics:

e "Basic Monitoring Configuration" on page 14

e "Advanced Configuration " on page 15

Basic Monitoring Configuration

1. Navigate to Groups > List.

2. Select Add.

3. Enter a Name that represents the Aruba device infrastructure from a security, geographical, or departmental
perspective and select Add.

4. You will be redirected to the Groups > Basic page for the Group you just created. On this page you will need
to verify and/or change the following Aruba-specific settings.
a. Find the SNMP Polling Periods section of the page, as illustrated in Figure 6.
b. Verify that the Override Polling Period for Other Services option is set to Yes.
c. Verify that Client Data Polling Period is set to 10 minutes. Do not configure this interval lower than 5

minutes.

Enabling the SNMP Rate Limiting for Monitored Devices option in the previous chapter adds a small delay

- between each SNMP Get request, thus the actual polling interval is 12 minutes for 10 minute polling interval.

d. Verify that the Device-to-Device Link Polling Period option is set to 30 minutes.
e. Verify that the Rogue AP and Device Location Data Polling Period option is set to 30 minutes.
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Figure 6: SNMP Polling Periods section of Groups > Basic

SNMP Polling Periods

Up/Down Status Polling Period: 5 minutes

Override Polling Period for Other Services: © Yes ® No

AP Interface Polling Period:

Client Data Polling Period:

Thin AP Discovery Polling Period:

Device-to-Device Link Polling Period:

802.11 Counters Polling Period:

Rogue AP and Device Location Data Polling Period:

CDP Neighbor Data Polling Period:

Mesh Discovery Polling Period: 15 minutes

5. Locate the Aruba section of this page. See Figure 7.

~

6. Configure the proper SNMP Version for monitoring the Aruba infrastructure.

Figure 7: Group SNMP Version for Monitoring

SNMP Version:
Offload WMS Database:

Aruba GUI Config:

Manage local configuration on controllers:
This option enables/disables the management of local configuration including
audit, push and import operations

Ignore Rogues Discovered by Remote APs:
Delete Certificates On Controller:

Archive Controller/Switch Backups:

7. Click Save and Apply when you are done.

Advanced Configuration

2c

Yes

Yes ©

Yes ©

) Yes

) Yes

Yes ©

No

No

Mo

Mo

Mo

Mo

Refer to the AirWave 8.2.x Controller Configuration Guide located at Home > Documentation for detailed

instructions.
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CAUTION

Chapter 4
Discovering Aruba Infrastructure

AirWave utilizes the Aruba topology to efficiently discover downstream infrastructure. This section guides you
through the process of discovering and managing your Aruba device infrastructure.

Refer to the following earlier sections in this document before attempting discovery:
e "Configuring AirWave for Global Aruba Infrastructure" on page 8
e "Configuring an Aruba Group " on page 14

The following topics in this chapter walk through the basic procedure for discovering and managing Aruba
infrastructure:

e "Discovering or Adding Master Controllers" on page 16
e "Local Controller Discovery" on page 18

e "Thin AP Discovery" on page 18

Always add one controller and its affiliated Thin APs into management or monitoring mode in a serial fashion, one ata
time. Adding new devices is a very CPU intensive process for AirWave and can quickly overwhelm all of the processing
power of the server if hundreds of Thin APs are added (migrated from New to Managed or Monitoring) simultaneously.

Discovering or Adding Master Controllers

Scan networks containing Aruba master controllers from the Device Setup > Discover page, or manually enter
the master controller by following these steps in the Device Setup > Add page:

1. Select the Aruba Device type and select Add. The page illustrated on Figure 8 appears.
2. Enter the Name and the IP Address for the controller.
3. Enter SNMP Community String, which is required field for device discovery.

Be sure to note the community string because it must match the SNMP trap community string, which is
configured later in this document.
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Figure 8: Aruba Credentials in Device Setup > Add

Configure default credentials on the Communication page.

Device Communications

Name:

Leave name blank to read it from device

IP Address:

SNMP Port: 161

SSH Port: 22

Community String: CIITITTYTY )
Confirm Community String: essssssses

SNMPV3 Username:

Auth Password:

Confirm Auth Password:

SNMPV3 Auth Protocol: SHA-1 ~

Privacy Password:

Confirm Privacy Password:

SNMPV3 Privacy Protocol: DES v

Telnet/SSH Username: admin

Telnet/55H Password: eessseseee

Confirm Telnet/SSH Password: ssssssssee

"enable” Password: eesssssces

Confirm "enable" Password: eesssesses
Group: APs “
Folder: Top v

o Update group settings based on this device's current configuration

®  Monitor Only (no changes will be made to device)

Manage read/write (group settings will be applied to device)

4. Enter the required fields for configuration and basic monitoring:

= Telnet/SSH user name
» Telnet/SSH password
= Enable password
5. Enter the required fields for WMS Offload

= SNMPv3 authentication protocol (must be SHA-1)

= SNMPv3 privacy protocol (must be DES)
= SNMPv3 user name

= Authentication password

= Privacy password

NOTE

The protocols for SNMPv3 authentication and SNMPv3 privacy must be SHA-1 and DES in order for WMS

Offload to work.

17 | Discovering Aruba Infrastructure
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CAUTION

CAUTION

NHOTE

If you are using SNMPv3, and the controller's date/time is incorrect, the SNMP agent will not respond to SNMP requests
from the AirwWave SNMP manager. This will result in the controller and all of its downstream access points showing as
Down in AirWave.

6. Assign the controller to a Group and Folder.
7. Ensure that the Monitor Only option is selected.

If you select Manage read/write, AirWave will push the group setting configuration, and existing device configurations
will be deleted/overwritten.

8. Select Add.

9. Navigate to the Devices > New page.

10.Select the Aruba master controller you just added from the list of new devices.
11.Ensure Monitor Only option is selected.

12.Select Add.

Local controllers are added to AirWave via the master controller by a discovery scan, or manually added in
Device Setup > Add. After waiting for the Thin AP Polling Period interval or executing a Poll Now command
from the Devices > Monitor page, the local controllers will appear on the Devices > New page.

Add the local controller to the Group defined previously. Within AirWave, local controllers can be split away from
the master controller's Group.

Local Controller Discovery/monitoring may not work as expected if AirWave is unable to communicate directly
with the target device. Be sure and update any ACL/Firewall rules to allow AirWave to communicate with your
network equipment.

Thin APs are discovered via the local controller. After waiting for the Thin AP Polling Period or executing a Poll
Now command from the Devices > Monitor page, thin APs will appear on the Devices > New page.

Add the thin APs to the Group defined previously. Within AirWave, thin APs can be split away from the
controller's Group. You can split thin APs into multiple Groups if required.
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Chapter 5

AirWave and Aruba Integration Strategies

This section describes strategies for integrating AirWave and Aruba devices and contains the following topics:

e '"Integration Goals" on page 20

e "Example Use Cases" on page 21

e "Prerequisites for Integration" on page 22

e "Enable Controller Statistics Using AirWave" on page 22
e "WMS Offload with AirWave" on page 23
e "Define AirWave as a Trap Host Using the ArubaOS CLI" on page 24

e "Understanding WMS Offload Impact on Aruba Infrastructure" on page 25

Integration Goals

Table 2 summarizes the types of integration goals and strategies for meeting them in certain architectural

contexts:

Table 2: Integration Goals in All Masters or Master/Local Architectures

Integration Goals

Rogue And Client Info

All Masters
Architecture

Master/Local
Architecture

enable stats

Rogue containment only

ssh access to controllers

ssh access to controllers

Rogue And Client
containment

WMS Offload

WMS Offload

Reduce Master Controller
Load

WMS Offload debugging off

IDS And Auth Tracking

Define AirWave as a trap host

Define AirWave as a trap host

Track Tag Location

enable Real Time Location
System (RTLS) WMS Offload

enable RTLS WMS Offload

Management (ARM)

Channel Utilization enable Application Monitoring | enable AMON
(AMON)

Spectrum enable AMON enable AMON

Traffic Analysis Visibility enable AMON enable AMON

UCC Visability enable AMON enable AMON

Health Information enable Adaptive Radio enable ARM

Key integration points to consider include the following:

AirWave 8.2.11.1 | Best Practices Guide
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e IDS Tracking does not require WMS Offload in an all-master or master/local environment.
o |IDS Tracking does require enable stats in a master/local environment.

o  WMS Offload will hide the Security Summary tab on master controller's web interface.

o WMS Offload encompasses enable stats or enable stats is a subset of WMS Offload.

e Unlessyou enable stats on the local controllers in a master/local environment, the local controllers do not
populate their MIBs with any information about clients or rogue devices discovered/associated with their
APs. Instead the information is sent upstream to master controller.

The following are example use cases of integration strategies:
e "When to Use Enable Stats" on page 21

e "When to Use WMS Offload" on page 21

e "When to Use RTLS" on page 21

e "When to Define AirWave as a Trap Host" on page 22

e "When to Use Channel Utilization" on page 22

When to Use Enable Stats

You want to pilot AirWave, and you do not want to make major configuration changes to their infrastructure or
manage configuration from AirWave.

Enable Stats still pushes a small subset of commands to the controllers via SSH.

HOTE

See "Enable Controller Statistics Using AirWave" on page 22.

When to Use WMS Offload

e You have older Aruba infrastructure in a master/local environment and the master controller is fully taxed.
Offloading WMS will increase the capacity of the master controller by offloading statistics gathering
requirements and device classification coordination to AirWave.

e You want to use AirWave to distribute client and rogue device classification amongst multiple master
controllers in a master/local environment or in an All-Masters environment.

o Seethe following topics:
= "WMS Offload with AirWave" on page 23
m "Understanding WMS Offload Impact on Aruba Infrastructure" on page 25
m "WMS Offload Details" on page 50

When to Use RTLS

e Ahospital wants to achieve very precise location accuracy (5 -15 feet) for their medical devices which are
associating to the WLAN.

e You want to locate items utilizing Wi-Fi Tags.

E RTLS can negatively impact your AirWave server's performance.

NOTE

e See"Leveraging RTLS to Increase Accuracy" on page 52.
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When to Define AirWave as a Trap Host

e Youwant to track IDS events within the AirWave Ul.

e You arein the process of converting their older third-party WLAN devices to Aruba devices and want a unified
IDS dashboard for all WLAN infrastructure.

o You want to relate Auth failures to a client device, AP, Group of APs, and controller. AirWave provides this
unique correlation capability.

See "Define AirWave as a Trap Host Using the ArubaOS CLI" on page 24.

When to Use Channel Utilization

e You have a minimum version of Aruba0OS 6.1.0.0.

Prerequisites for Integration

If you have not discovered the Aruba infrastructure or configured credentials, refer to the previous chapters of
this book:

e "Configuring AirWave for Global Aruba Infrastructure" on page 8
e "Configuring an Aruba Group " on page 14
e "Discovering Aruba Infrastructure" on page 16

Enable Controller Statistics Using AirWave
To enable stats on the Aruba controllers, follow these steps:

1. Navigate to AMP Setup > General and locate the Device Configuration section.
2. Set the Allow WMS Offload Configuration in Monitor-Only Mode field to Yes, as shown in Figure 9:

Figure 9: WMS Offload Configuration in AMP Setup > General

Device Configuration

Guest User Configuration: Enabled for device
Allow WMS Offload : i
configuration in monitor-only © Yes @ No
mode:

Allow disconnecting users while  © yae ® g

in monitor-only mode:

Use Global Aruba Configuration: 2

Changing this setting may require © Yes @ No

importing configuration on your devices.
3. Navigate to Groups > Basic for the group that contains your Aruba controllers.
4. Locate the Aruba section on the page.

5. Set the Offload WMS Database field to No, as shown in Figure 10:
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NOTE

CAUTION

Figure 10: Offload WMS Database field in Groups > Basic

SNMP Version: 2c v
Offload WMS Database: @ Yes @ No
Aruba GUI Config: @ Yes © No

Manage local configuration on controllers: ) )
This option enables/disables the management of local configuration including @ Yes © No
audit, push and import operations

Ignore Rogues Discovered by Remote APs: © Yes @ No
Delete Certificates On Controller: © Yes @ No
Archive Controller/Switch Backups: @ Yes O No

6. Select Save and Apply.
7. Select Save.

This will push a set of commands via SSH to all Aruba local controllers. AirWave must have read/write access to
the controllers in order to push these commands.

This process will not reboot your controllers.

If you do not follow the above steps, local controllers will not be configured to populate statistics. This decreases
AirWave's capability to trend client signal information and to properly locate devices. See "ArubaOS CLI" on page 40 for
information about how to utilize the ArubaOS CLI to enable stats on Aruba infrastructure.

If your credentials are invalid or the changes are not applied to the controller, error messages will display on the
controller's Devices > Monitor page under the Recent Events section. If the change fails, AirWave does not
audit these setting (display mismatches) and you will need to apply to the controller by hand. See "ArubaOS CLI"
on page 40 for detailed instructions.

These are the commands pushed by AirWave while enabling WMS Offload. Do not enter these commands:

configure terminal

no mobility-manager <Active WMS IP Address>
wms

general collect-stats enable
stats-update-interval 120

show wms general

write mem

WMS Offload with AirWave

To offload WMS on the Aruba controllers using AirWave:

1. In AMP Setup > General, locate the Device Configuration section and enable or disable Allow WMS
Offload Configuration in Monitor-Only Mode.
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2. Select Save and Apply. This will push a set of commands via SSH to all Aruba master controllers. If the
controller does not have an SNMPv3 user that matches the AirWave database it will automatically create a
new SNMPv3 user. AirWave must have read/write access to the controllers to push these commands

3. Navigate to Groups > Basic and locate the Aruba section.
4. Set the Offload WMS Database field to Yes.

This process will not reboot your controllers. See "CLI Commands" on page 40 for information on how to utilize
the ArubaOS CLI to enable stats for WMS Offload.

N

HOTE

The SNMPv3 user's Auth Password and Privacy Password must be the same.

>

CAUTION

Do not enter these commands; these are pushed by AirWave while enabling WMS Offload.

configure terminal

mobility-manager <AMP IP> user <AMP SNMPv3 User Name> <AMP Auth/Priv PW>

stats-update-interval 120

write mem

AirWave will configure SNMPv2 traps with the mobile manager command.
NOTE

To ensure the AirWave server is defined as a trap host, access the command line interface of each controller

(master and local), enter enable mode, and issue the following commands:

(Controller-Name) # configure terminal

Enter Configuration commands, one per line. End with CNTL/Z

(Controller-Name) (config) # snmp-server host <AMP IP ADDR> version 2c <SNMP Community String of

Controller>

Ensure the SNMP community matches those that were configured in "Configuring AirWave for Global Aruba
— Infrastructure" on page 8.

(Controller-Name) (config) # snmp-server trap source <Controller-IP>

(Controller-Name) (config) # write mem

AirWave supports SNMP v2 traps and SNMP v3 informs in ArubaOS 3.4 and higher. SNMP v3 traps are not
NoTA supported.

Ensuring That IDS and Auth Traps Display in AirWave
Validate your ArubaOS configuration by exiting the configure terminal mode and issue the following command:
(Controller-Name) # show snmp trap-list

If any of the traps in the output of this command do not appear to be enabled, enter configure terminal
mode and issue the following command:

(Controller-Name) (config) # snmp-server trap enable <TRAPS FROM LIST ABOVE>

| 4 See "ArubaOSs CLI" on page 40 for the full command that can be copied and pasted directly into the
ArubaOS CLI.

NOTE

(Controller-Name) (config) # write mem
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Ensure the source IP of the traps match the IP that AirWave uses to manage the controller, see Figure 11.
Navigate to Devices > Monitor to validate the IP address in the Device Info section.

Figure 11: Verify IP Address on Devices > Monitor Page

Status: Up (OK)

Configuration: Good

Firmware: 6.4.4.3 Licenses

Upstream Device: s Upstream Port:

Controller Role: Master

Type: Aruba 7220 Last Contacted: 1/22/2016 12:33 PM PST Uptime: 33 days 12 hrs 27 mins.
LAN MAC Address: 00:1A:1E:00:0E:28 Serial: BB0000118

Location: 1344-1 Rack 28 Contact 115 3.77 Mbps Good

I IP Address: 10.11.0.11 I APs: 38 Clients: 115 Usage:  3.77 Mbps

VPN Sessions: 0 VPN Usage:
Quick Links: Open controller web U ~ Run command. e

Notes:

Verify that there is a SNMPv2 community string that matches the SNMP Trap community string on the
controller.

(Controller-Name) # show snmp community
SNMP COMMUNITIES

(Controller-Name) # #show snmp trap-host

SNMP TRAP HOSTS

HOST VERSION SECURITY NAME PORT TYPE TIMEOUT RETRY

10.2.32.4 SNMPv2c public 162 Trap N/A N/A

Understanding WMS Offload Impact on Aruba Infrastructure

When offloading WMS, it is important to understand what functionality is migrated to AirWave and what
functionality is deprecated.

The following ArubaOS tabs and sections are deprecated after offloading WMS:

e Plan - The tab where floor plans are stored and heatmaps are generated. Before offloading WMS, ensure that
you have exported floor plans from ArubaOS and imported them into AirWave. All functionality within the
Plan Tab is incorporated with the VisualRF module in AirWave.

o Dashboard > Security Summary - The Security Summary section (Figure 12) disappears after offloading
WMS. The data is still being processed by the master controller, but the summary information is not available.
You must use AirWave to view data for APs, clients and events in detail and summary from.

= AirWave displays information on Rogue APs in the RAPIDS > Overview pages.

= Information on Suspected Rogue, Interfering and known interfering APs is available in AirWave on each
Devices > Manage page.

= |IDS events data and reports appear on AirWave's Reports > Generated > IDS Events page.
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Figure 12: Security Summary on the Master Controller
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See "Rogue Device Classification" on page 35 for more information about security, IDS, WIPS, WIDS,

classification, and RAPIDS.
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Chapter 6
Aruba Specific Capabilities

This section discusses Aruba specific capabilities in AirWave and contains the following topics:
e "Aruba Traps for RADIUS Auth and IDS Tracking" on page 28

e "Remote AP Monitoring" on page 29

e "ARM and Channel Utilization Information" on page 30

e "Viewing Controller License Information" on page 35

e "Rogue Device Classification" on page 35

e "Rules-Based Controller Classification" on page 38

Aruba Traps for RADIUS Auth and IDS Tracking

The authentication failure traps are received by the AirWave server and correlated to the proper controller, AP,
and user.

View a list of recent RADIUS authentication issues by navigating to the Home >Overview page, and selecting
the RADIUS Issues link in the Alert Summary table at the bottom of the page.Figure 13 shows all
authentication failures related to RADIUS data.

Figure 13: RADIUS Issues Summary

RADIUS Issues for devices in folder Top and subfolders | Return to Home Overview

Event Type a Last 2 Hours Last 24 Hours Total
Authentication server request timed out for aruba-supersvr (o] 5 17
Authentication server request timed out for clearpass-ebc 11 60 17
Authentication server request timed out for clearpass-hq2 5 25 54
Authentication server request timed out for hgsvc01 0 0 3
Authentication server request timed out for sjc-cphpe2 (o] 2 2!
Authentication server request timed out for sjccppmsub02 2 29 72
Client authentication failed 9 66 116
7 RADIUS Issue Event Types 10 70 121

[ ] I

1-20 » 0f 12,121 RADIUS Issues Page 1 »of 606 > >| Resetfilters Choose columns Export CSV

Event Username | Client MAC Address  Client IP AP/Device BSSID Radio C
] Client authentication failed for F8:95:C7:FF:B2:94 xjma F8:95:C7:FF:B2:94 0.0.0.0 1310-325 AC:A3:1E:53:B3:F0  802.11ac et
[} Client authentication failed for 00:00:00:00:00:00 - 00:00:00:00:00:00 10.69.2.253 - - - aj
=] Client authentication failed for 00:24:D7:EB:22:68 kenc 00:24:D7:EB:22:68 0.0.0.0 1341-AP123  AC:A3:1E:55:91:B0 802.11ac a
o Client authentication failed for 00:00:00:00:00:00 = 00:00:00:00:00:00 10.69.2.253 - - - aj

There are two ways to navigate to the list of recent IDS events. You can go to the Home >Overview page and
select the IDS Events link in the Alert Summary table at the bottom of the page, or go directly to RAPIDS >
IDS Events. The IDS Events Summary page includes a table that shows the numbers of events in each IDS
category, as well as a sortable table of each event. (See Figure 14.)
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Figure 14: IDS Events in AirlWave

IDS Events for devices in folder Top and subfolders | View all IDS Events

Attack a Last 2 Hours Last 24 Hours
Ad-hoc Network Detected 11 27
AP Flood Attack 208 2308
AP Impersonation ] 23
AP Spoofing Detected ] 3
Block ACK Attack 31 97
Channel Rate Anomaly ] 1
Client Flood Attack 222 1438
CTS Packets Rate Anomaly 8 259
Deauth Broadcast 1 4
Disconnect Station Attack 13 32
FATA-Jack Attack 48 160
Hotspotter Attack 7 38
HT 40MHz Intolerance 88 605
Information Element Overflow 20 183
Invalid Address Combination 13 115
Invalid MAC OUI 77 886

Total

27

4066

213

23

2676

309

63

303

64

903

313

201

1571

< 0

1-20 w of 20,625 IDS Events Page 1w of 1,032 > >| Reset filters Choose columns Export CSV

Severityw  Category w Scopew Attack v
i} Highest Rogue Activity Client Station Associated to Rogue AP
o Highest Rogue Activity Client Station Associated to Rogue AP

Remote AP Monitoring

To monitor remote APs, follow these steps:

Detail

Station Associated to Rogue AP

Station Associated to Rogue AP

1. Fromthe Devices > List page, filter on the Remote Device column to find remote devices.

2. Toview detailed information about the remote device, select the device name. The page illustrated in Figure

15 appears.
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Figure 15: Remote AP Detail Page

Monitoring ss-155 in group APs in folder Top _
Poll Controller Now
ﬂ This Device is in moniter-only mode.

Device Info

Help

Status: Up

Configuration: Good

Controller: 7210-alpha-1 Aruba AP Group: | India-raps Upstream Device:

Type: Aruba RAP-155P I Remote Device: Yes I Last Contacted: 1/21/2016 10:21 PM PST
LAN MAC Address: = 00:0B:86:8F:68:12 Serial: CC0003393

IP Address: 1.1.1.20 Clients: 26 Usage: 232 Kbps

Quter IP: 27.251.187.226 Remote LAN IP: 192.168.10.167  Active Uplink: Ethernet

Quick Links: Open controller web Ul. v

Notes:

4 1 | b

GELILE

INDEX & NAME MAC ADDRESS CLIENTS USAGE(KBPS) CHANNEL TXPOWER ANTENNATYPE ROLE SsID

1 802.11bgn  6C:F3:7F:78:F3:80 26 232 Kbps 1. 20 dBm External Access  alpha-voip, alp
2 802.11an 6C:F3:7F:78:E3:90 - - - 23 dBm External Access  alpha-voip, alp

a I | +

USB Interfaces

INDEX & NETWORK SERVICE LEVEL STATUS OPERATIONAL STATUS RSSI USAGE

1 - Not Plugged Down - 0 bps

< Il v

Wired Interfaces

INTERFACE NAME 4 MAC ADDRESS CLIENTS ADMIN STATUS OPERATIONAL STATUS  TYPE DUPLEX ARUBA PORT MO
Enet0 00:0B:86:8F:68:12 0 Up Up gigabitEthernet  Full N/A

Enet1 00:0B:86:8F:68:13 0 Up Up gigabitEthernet ~ Half Split

Enet2 00:0B:86:8F:68:14 0 Up Up gigabitEthernet  Half Split

Enet3 00:0B:86:8F:68:15 0 up Down gigabitEthernet  Half split

Enet4 00:0B:86:8F:68:16 0 up Down gigabitEthernet  Half split

4 T | r

You can also see if there are users plugged into the wired interfaces in the Connected Clients list below the
Clients and Usage graphs at the bottom of this page.

E This feature is only available when the remote APs are in split tunnel and tunnel modes.

ARM and Channel Utilization Information

ARM statistics and Channel utilization are very powerful tools for diagnosing capacity and other issues in your
WLAN.

Navigate to an Devices > Monitor page for any AP that supports ARM and channel utilization.

N

In the Radios table, select a radio link under the Name column for a radio.

3. The graphs default to Client and Usage. Select an icon for each to change the graphs to display Radio Channel
and Channel Utilization.
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Figure 16: ARM and Channel Utilization Graphs

AP Monitoring | Radio Statistics
Monitoring 802.11ac radio for AP 1344-2-AP17

w

B02.11 Radio Counters Summary (frames/sec)

CURRENT LAST HOUR LAST DAY LAST WEEK
Unacked ] ] 1 3
Retries ] o 4 64
Failures 0 o 0 o
Dup Frames 1} 0 [} 3
FCS Errors 4 6 23 21

Radio Channel

Clients

Fadio N

75

50

75

25

s0
25 15:30 16:00 16:30 17:00 17:30

15:30 16:00 16:30 17:00 17:30

Channel Interference

See the AirWave 8.2.11.1 User Guide in Home > Documentation more information about the data that displays
in the Radio Statistics page for these devices.

VisualRF and Channel Utilization

Navigate to a floor plan by navigating to VisualRF > Floor Plans page.

Click the list link at the top of the Floor Plans page, and select a floor plan from the list.
Click the View tab

Select the Overlays menu.

Select the Ch. Utilization overlay.

Select Current or Maximum (over last 24 hours).

No vk wh =

Use the Data Set drop-down list to display Total, Receive (Rx), Transmit (Tx), or Interference utilization
data.

8. Select the option to view information for the current floor only, or to include information about the floor
above, and/or the floor below.

9. Select afrequency (5 GHz and/or 2.4 GHz).
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Figure 17: Overlays

Floor 2

Properties  View  Edit

—_—
Devices
v @ APs >
v B Clients >
# Interferers >
@ Rogues »
Q) Tags >
Client Overlays
AppRF »
v Client Health
ucc >
AP Overlays

v Ch. utilization .
pu]

Data Set

Freguencies

Floors

Show Qverlay as Grid?

@  Current
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Current
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Figure 18: Channel Utilization in VisualRF (Interference/2.4 GHz)

AirWave 8.2.11.1 | Best Practices Guide

Aruba Specific Capabilities | 32



Configuring Channel Utilization Triggers

1. Navigate to System > Triggers and select Add.
2. Select Channel Utilization from the Type drop-down menu as seen on Figure 19:

Figure 19: Channel Utilization Trigger

|
g

Trigger
Type: Channel Utilization ~
Severity: Warning ~
ED:r‘IaStE:LtEs'. 75 seconds, "1 hr 15 mins’ 5 Minutes

Matching conditions: @ p© Any

Available Conditions: Interference (%), Radio Type, Time Busy (%), Time Receiving (%), Time Transmitting
(%6)

m New Trigger Condition

OFTION CONDITION VALUE
50

nterference (%) v >m W '
70

Time Busy (%) v B iy v

Trigger Restrictions

Folder: Top v
Include subfolders: @ vas © No
Group: ProVision Switches v/

Alert Notifications

Notes:

Enter the duration evaluation period.

Click the Add New Trigger Condition button.

Create a trigger condition for Radio Type and select the frequency to evaluate.
Select total, receive, transmit, or interference trigger condition.

Set up any restrictions or notifications. (Refer to the AirWave 8.2.11.1 User Guide in Home >
Documentation for more details.)

When you are finished, click Add.

No v kW

®

Viewing Channel Utilization Alerts

You can view Channel Utilization alerts from the Devices > Monitor page and on the System > Alerts page.
To view channel utilization alerts on the Devices > Monitor page:

1. Navigate to the Devices > list page and select a device.

2. Navigate to the Devices> Monitor page for that device.

3. Scrolldown to the Alert Summary table and select AirWave Alerts.
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Figure 20: Channel Utilization alerts

Alerts for ITC in group Ethersphere-Ims in folder Top > Sunnyvale HQ | Return to AP/Device Monitor Page

Attack a Last 2 Hours Last 24 Hours Total
Channel Utilization Interference (%) >= 20% for 5 minutes 0 2 4
1-1 wof 1Alerts Pagelwof1 >| Choosecolumns Export CSV

a Trigger Type a Trigger Summary Triggering Agent Time Severity

Channel Utilization Interference (%) >= 20% for 5 minutes 1341-AP116 (radio 802.11bgn) 1/21/2016 8:03 PM PST Normal

1-1 wof 1Alerts Page1w~of1
Select All - Unselect All

o

To view channel utilization alerts on the System > Alerts page:

1. Navigate to the System > Alerts page.
2. Sort the table using the Trigger Type column to display Channel Utilization alerts.

Figure 21: Channel Utilization alerts on the System > Alerts page

1-50 v of 64 Alerts Paqi 1wof 2 > >l Choose columns Export CSV

Trigger Type a Trigger Summary Triggering Agent Time Severity Details Notes
B Channel Utilization Interference (%) >= 20% for 5 minutes 1341-AP116 (radio 802.11bgn) 1/21/2016 8:03 PM PST Normal - don't edit
B Channel Utilization Interference (%) >= 20% for 5 minutes AP7cOe.cef5.ae14 (radio 802.11bgn)  1/21/2016 6:55 PM PST Normal - don't edit
B Channel Utilization Time Busy (%) >= 80% for 10 minute 1341-AP112 (radio 802.11bgn) 1/21/2016 11:16 PM PS Normal
B Channel Utilization Radio Type is 2.4Ghz (802.11 b/g/n) and Time Busy (%) >= (more...  1341-AP115 (radio 802.11bgn) 1/22/2016 2:24 PM PST Normal
B Channel Utilization Interference (%) >= 20% for 5 minutes 1341-AP115 (radio 802.11bgn) 1/22/2016 1:37 PM PST Normal - don't edit

View Channel Utilization in RF Health Reports
1. Navigate to Reports > Generated.
2. Find and select an RF Health report.

3. Scroll down to view the Most Utilized by Channel Usage (5 GHz) and Most Utilized by Channel Usage
(2.4 GHz) graphs.
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Figure 22: Channel Utilization in an RF Health Report (partial view)

Most Utilized by Channel Usage (5 GHz)

Rank a Device Channel Busy (%) Interference (%) Clients Usage Location Controller Folder Group

1 1341-AP122 2244 0.39 & 417.48 Kbps = Chuckwagon Top > Sunnyvale HQ Aruba HQ
2 1341-AP121 22.05 0.00 1 155.74 Kbps = Chuckwagon Top > Sunnyvale HQ Aruba HQ
£l 1341-AP131 22.05 0.00 i 190.26 Kbps - Chuckwagon Top > Sunnyvale HQ Aruba HQ
4 1341-AP105 21.65 -0.00 1 231.72 Kbps 2 Chuckwagon Top > Sunnyvale HQ Aruba HQ
5 1341-AP120 21.26 -0.00 0 4.10 Kbps - Chuckwagon Top > Sunnyvale HQ Aruba HQ
6 1341-AP127 20.87 0.00 0 11.98 Kbps i Chuckwagon Top > Sunnyvale HQ Aruba HQ
7 1341-AP130 20.87 0.00 3 628.27 Kbps = Chuckwagon Top > Sunnyvale HQ Aruba HQ
8 1341-AP107 20.47 -0.39 3 406.21 Kbps - Chuckwagon Top > Sunnyvale HQ Aruba HQ
5 1341-AP117 20.47 -0.00 1 24.13 Kbps = Chuckwagon Top > Sunnyvale HQ Aruba HQ
10 1341-AP112 20.08 -0.39 1 87.25 Kbps = Chuckwagon Top > Sunnyvale HQ Aruba HQ

< ] I

Rank a Device Channel Busy (%) Interference (%) Clients = Usage Location Controller Folder Group

1 1341-AP125 705 17.32 0 17.48 Kbps - Chuckwagon Top > Sunnyvale HQ Aruba HQ
2 AP7c0e.cef5.ae14 76.77 76.77 0 11.98 Kbps  default location Cisco8510 Top Cisco Gear
3 1341-AP127 74.02 14.96 0 8.08 Kbps - Chuckwagon Top > Sunnyvale HQ Aruba HQ
4 APd072.dce0.225c 73.23 73.23 0 6.21 Kbps default location Cisco7500 Top Cisco Gear
5 1341-X-AP09 72.83 26.77 0 4.13 Kbps = alpo Top > Sunnyvale HQ Aruba HQ
6 1341-AP114 70.08 10.63 0 68 bps - Chuckwagon Top > Sunnyvale HQ Aruba HQ
7 1341-AP124 69.29 9.84 0 47 bps - Chuckwagon Top > Sunnyvale HQ Aruba HQ
8 1341-AP132 68.50 9.06 0 2bps - Chuckwagon Top > Sunnyvale HQ Aruba HQ
9 1341-AP117 67.32 10.24 0 0 bps % Chuckwagon Top > Sunnyvale HQ Aruba HQ
10 1341-AP116 66.54 8.27 0 0bps i Chuckwagon Top > Sunnyvale HQ Aruba HQ

< i 1

Viewing Controller License Information

Follow these steps to view your controller's license information in AirWave:

—_

Navigate to the Devices > List page and select a controller.

N

Navigate to the Devices > Monitor page for that controller.

In the Device Info table at the top of the page, select the Licenses link. A pop-up window appears listing all
licenses.

w

Figure 23: Controller License Popup from the Devices > Monitor page

License Table for Chuck:

Service Type & Installed Expires Flazg Key

Access Points: 512 10/21/2012 E  F/luldyB-tPp9X7q5-SRXPUJRI-gKmr5CPP-j2D
Internal Test Functions 10/16/2015 E  nbqlfltt-Eq44rroM-06zsbiXT-9OHtEWFPV-3AxeZ
Next Generation Policy Enforcement Firewall Module: 512 10/21/2012 E  XxD6aduH-BGWeat+tXP-DPRYRrg7-eut+loHA
Policy Enforcement Firewall for VPN users 10/21/2012 E  Eb/n2d02-9AeE6co]-3100xfij-iaBuTtpX-Bilsw6]
RF Protect: 512 10/21/2012 E  859Ge/BG-nQnXivib- WMmHOVDT-dCJO0vQ
Voice Service Module: 8192 10/20/2012 E  YNIGZ88x-UtVHPlv-WKSX1LzM-564tsWH8-x

Rogue Device Classification

Complete the steps in this section if you have completed the WMS Offload procedure. After offloading WMS,
AirWave maintains the primary ARM, WIPS, and WIDS state classification for all devices discovered over-the-air.
See Table 3 below for details.
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CAUTION

Table 3: WIPS/WIDS to AirWave Controller Classification Matrix

AirWave Controller Classification ArubaOS
(WIPS/WIDS)

Unclassified (default state) Unknown

Valid Valid

Suspected Valid

Suspected Valid

Suspected Neighbor

Interfering

Neighbor

Known Interfering

Suspected Rogue

Suspected Rogue

Rogue

Rogue

Contained Rogue

DOS

To check and reclassify rogue devices, follow these steps:

Navigate to the RAPIDS > Detail page for a rogue device (see Figure 24 below).

Name:

Acknowledge:

Controller Classification:
Match Type:

SSID:

RAPIDS Classification:

Classification Rule:

RAPIDS Classification Override:

Threat Level:

Threat Level Override:

Radio MAC Address:
Radio Vendor:

LAN MAC Address:
LAN Vendor:

OUl Score:
Operating System:
OS Detail:

Last Scan:

Figure 24: Rogue Detail Page lllustration

Aruba Netw-D3:F9:00

© Yes @ No

Suspected Rogue

meell1341
Suspected Rogue

Signal strength > -75 dBm

No Override v

Aruba Networks

Model: - First Discovered:

IP Address: - First Discovery Method:
Confidence: 20

Match Method: - Match MAC:

First Discovery Agent:

Channel: 1 Last Discovered:

WEP: No  Last Discovery Method:
WPA: Yes  Last Discovery Agent:
Network Type: AP Signal:

Current Associations: 0

Max Associations: (1]

2. Select the proper classification for the device from the RAPIDS Classification Override drop-down list.

9/2/2015 2:36 PM PDT

Wireless AP scan

Match IP Address:

1/22/2016 2:24 PM PST

Wireless AP scan

1341-X-AP11

-20

Changing the controller's classification within the Airwave WebUI will push a reclassification message to all controllers
managed by the AirWave server that are in Groups with Offloading the WMS database set to Yes. To reset the
controller classification of a rogue device on AirWave, change the controller classification on the Airwave WebUI to
unclassified.

Controller classification can also be updated from RAPIDS > List via the Modify Devices link.
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CAUTION

All rogue devices will be set to a default controller classification of unclassified when WMS is first offloaded
except for devices classified as valid. Rogue devices classified in ArubaOS as valid will also be classified within
AirWave as valid for their controller classification as well. As APs report subsequent classification information
about rogues, this classification will be reflected within AirWave WebUI and propagated to controllers that
AirWave manages. The device classification reflected in the controller's WebUI and in the AirWave WebUI will
probably not match, because the controller/APs do not reclassify rogue devices frequently.

To update a group of devices' controller classification to match the ArubaOS device classification, navigate to
RAPIDS > List and utilize the Modify Devices checkbox combined with the multiple sorting a filtering features.

Table 4: ARM to AirWave Classification Matrix

AirWave AOS (ARM)

Unclassified (default state) Unknown
Valid Valid
Contained DOS

1. Navigate to the Clients > Client Detail page for the user.
2. Inthe Device Info section, select the proper classification from the Classification drop-down list (see Figure
25):

Figure 25: User Classification

Detail for F4:AF:93:5C:89:89

Last Username: kartee

First Seen: 12/21/201511:  AM PST on 1341-AP98 for 20 mins
Last Seen: 1/15/2016 2:00 PM PST on 1341-AP115 for 50 mins
Device Type: O [ gsx

Network Interface Vendor: Unknown
AQS Device Type: 05X

Aruba HTTP Fingerprint: -

Classification: Unclassified v

Watched Client:

MNotes:

Changing User Classification within the AirWave WebUI will push a user reclassification message to all controllers
managed by the AirWave server that are in Groups with Offloading the WMS database set to Yes.

All users will be set to a default classification of unclassified when WMS is first offloaded. As APs report
subsequent classification information about users, this classification will be reflected within the Airwave WebUI
and propagated to controllers that AirWave manages. It is probable that the user's classification reflected in the
controller's WebUI and in the AirWave WebUI will not match, because the controllers/APs do not reclassify users
frequently.
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There is no method in the AirWave WebUI to update user classification before bulk to match the controller's
classification. Each client must be updated individually within the AirWave WebUI .

Rules-Based Controller Classification
This section contains the following topics:

e "Using RAPIDS Defaults for Controller Classification" on page 38
e "Changing RAPIDS Based on Controller Classification" on page 38

Using RAPIDS Defaults for Controller Classification

1. Navigate to the RAPIDS > Rules page and select the pencil icon beside the rule that you want to change.
2. Inthe Classification drop-down list, select Use Controller Classification (see Figure 26 below).
3. Click Save.

Figure 26: Using Controller Classification

RAPIDS Classification Rule

Rule name: Detected Wirelessly and On LAN

Classification: Suspected Neighbor v
RAPIDS Classification

Threat Level: valid

Enabled:

Detected on WLAN w m e

Device Classification

Device has been detected wirelessly: Use Controller Classification

(remove condition)

Changing RAPIDS Based on Controller Classification

1. Navigate to RAPIDS > Rules and select the desired rule.
2. Inthe Classification menu, select the RAPIDS classification.
3. Select Controller Classification (see Figure 27 below).
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Figure 27: Configure Rules for Classification

RAPIDS Classification Rule

Rule name: Detected Wirelessly and on LAN
Classification: Rogue v
Threat Level: 5 v
Enabled: @ Yes @ No

Detected on WLAN b m

sly: @ Yes @ No
(remove condition)

Wireline Properties

m

4. Click Add. A new Controller Classification field displays.
5. Select the desired controller classification to use as an evaluation in RAPIDS.
6. Click Save.
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Appendix A
CLI Commands

Enable Channel Utilization Events

Enabling these commands on ArubaOS versions prior to 6.1 can result in performance issues on the controller.

CAUTION

To enable channel utilization events utilizing the ArubaOS CLI, use SSH to access a local or master controller's
command-line interface, enter enable mode, and issue the following commands:

(Controller-Name) # configure terminal
Enter Configuration commands, one per line. End with CNTL/Z

(Controller-Name) (config) # mgmt-server type amp primary-server <AMP IP> profile <profile-name>
(Controller-Name) (config) # write mem

Enable Stats With the ArubaOS CLI

The following commands enable collection of statistics (up to 25,000 entries) on the master controller for
monitored APs and clients.

Do not use these commands if you use the AirWave WebUI to monitor APs and Clients. Enabling these
commands on ArubaOS versions prior to 6.1 can result in performance issues on the controller.

Use SSH to access the command-line interface of the master controller or Mobility Master, enter enable mode,
and issue the following commands:
(host) [mynode] # configure terminal

Enter Configuration commands, one per line. End with CNTL/Z

(host) [mynode] # ids wms-general-profile collect-stats
(host) [mynode] (IDS WMS General Profile) # exit
(host) [mynode] # write mem

Offload WMS Using the ArubaOS CLI

Do not use these commands if you use the AirWave WebUI to monitor APs and clients.

Additional commands can be used to offload WMS using the ArubaOS command-line interface or the AirWave
SNMP Walk. For information, see "ArubaOS CLI" on page 40.

ArubaOS CLI
Using ArubaOS 6.x

SSH into all ArubaOS 6.x controllers (local and master) , enter enable mode, and issue the following commands:

(Controller-Name) # configure terminal

Enter Configuration commands, one per line. End with CNTL/Z

(Controller-Name) (config) # mobility-manager <AMP IP> user <MMS-USER> <MMS-SNMP-PASSWORD>
(Controller-Name) (config) # write mem

AirWave 8.2.11.1 | Best Practices Guide Appendix A CLI Commands | 40



HOTE

This command allows the controller to communicate with an MMS server by creating an SNMPv3 user on the
controller with the default authentication protocol configured to SHA and privacy protocol DES. The user and
password must be at least eight characters because the Net-SNMP package in AirWave adheres to this IETF
recommendation. ArubaOS automatically creates Auth and Privacy passwords from this single password. If
mobility-manager is already using a preconfigured SNMPv3 user, ensure the privacy and authentication
passwords are the same.

Using ArubaOS 8.x

SSH into all ArubaOS 8.x Mobility Master and managed devices, enter enable mode, and issue the following
commands:

(host) [mm]) # configure terminal

Enter Configuration commands, one per line. End with CNTL/Z

(host) [mm] (config) #mobility-manager <AMP-IP> user <MMS-User> <MMS-Password> auth-prot md5
priv-prot DES

(Controller-Name) (config) # write mem

This command allows a managed device to communicate with a mobility manager server (MMS) and creates an
SNMPv3 user on the controller with the authentication protocol configured to MD5 and privacy protocol DES.
The user and password must be at least eight characters because the Net-SNMP package in AirWave adheres to
this IETF recommendation. ArubaOS automatically creates Auth and Privacy passwords from this single
password. If mobility-manager is already using a preconfigured SNMPv3 user, ensure the privacy and
authentication passwords are the same.

Use the following ArubaOS CLI commands to ensure that the master controller is properly pushing configuration
settings from the master controller to local controllers. This command ensures configuration changes made on
the master controller will propagate to all local controllers.

Do not use these commands if you use the AirWave WebUI to monitor APs and clients.

(Controller-Name) (config) # cfgm mms config disable
(Controller-Name) (config) # write mem

If you are experiencing performance issues on the master controller, ensure that debugging is disabled. It should
be disabled by default. Debugging coupled with gathering the enhanced statistics can put a strain on the
controller's CPU, so it is highly recommended to disable debugging.

To disable debugging, SSH into the controller, enter enable mode, and issue the following commands:

(Controller-Name) # show running-config | include logging level debugging

If there is output, then use the following commands to remove the debugging:
(Controller-Name) # configure terminal

Enter Configuration commands, one per line. End with CNTL/Z

(Controller-Name) (config) # no logging level debugging <module from above>
(Controller-Name) (config) # write mem
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To ensure local controllers are populating rogue information properly, use SSH to access the command-line
interface of each local controller or managed device, enter enable mode, and issue the following commands:

(host) [mynode] # configure terminal
Enter Configuration commands, one per line. End with CNTL/Z
(host) [mynode] # process restart wms

After executing the restart wms command in ArubaOS, you will need to wait until the next Rogue Poll Period on
AirWave and execute a Poll Now operation for each local controller or managed device on the Devices > List
page before rogue devices begin to appear in AirWave.

To ensure proper event correlation for IDS events when WMS is not offloaded to AirWave, access the command
line interface of each controller (master and local), enter enable mode, and issue the following commands:

(Controller-Name) # configure terminal

Enter Configuration commands, one per line. End with CNTL/Z
(Controller-Name) (config) # ids management-profile
(Controller-Name) (config) # ids general-profile <name>
(Controller-Name) (config) # ids-events logs-and-traps
(Controller-Name) (config) # write mem

To ensure the proper traps are configured on Aruba controllers, copy and paste the following command in config
mode:

snmp-server trap enable wlsxNUserAuthenticationFailed
wlsxAdhocNetworkBridgeDetected
wlsxAdhocNetworkBridgeDetectedAP
wlsxAdhocNetworkBridgeDetectedSta
wlsxAdhocNetworkDetected
wlsxAdhocUsingValidSSID
wlsxAPChannelChange
wlsxApFloodAttack
wlsxAPImpersonation
wlsxAPModeChange

wlsxAPPowerChange
wlsxAPSpoofingDetected
wlsxBlockAckAttackDetected
wlsxChannelFrameErrorRateExceeded
wlsxChannelFrameFragmentationRateExceeded
wlsxChannelFrameRetryRateExceeded
wlsxChannelRateAnomaly
wlsxChopChopAttack
wlsxClientAssociatedToHostedNetwork
wlsxClientAssociatingOnWrongChannel
wlsxClientFloodAttack
wlsxCTSRateAnomaly
wlsxDisconnectStationAttackAP
wlsxDisconnectStationAttackSta
wlsxEAPRateAnomaly
wlsxFataJdackAttack
wlsxFrameBandWidthRateExceeded
wlsxFrameFragmentationRateExceeded
wlsxFrameLowSpeedRateExceeded
wlsxFrameNonUnicastRateExceeded
wlsxFrameReceiveErrorRateExceeded
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wlsxFrameRetryRateExceeded

wlsxHostOfWirelessNetworkContainment

wlsxHotspotterAttackDetected
wlsxHT40MHzIntoleranceAP
wlsxHT40MHzIntoleranceSta
wlsxHtGreenfieldSupported
wlsxInvalidAddressCombination
wlsxInvalidMacOUIAP
wlsxInvalidMacOUISta
wlsxMalformedAssocRegDetected
wlsxMalformedAuthFrame

wlsxMalformedFramelLargeDurationDetected
wlsxMalformedFrameWrongChannelDetected

wlsxMalformedHTIEDetected
wlsxNAccessPointIsDown
wlsxNAccessPointIsUp
wlsxNAdhocNetwork
wlsxNAdhocNetworkBridgeDetectedAP
wlsxNAdhocNetworkBridgeDetectedSta
wlsxNAdhocUsingValidSSID
wlsxNAPMasterStatusChange
wlsxNAuthServerRegTimedOut
wlsxNDisconnectStationAttack
wlsxNIpSpoofingDetected
wlsxNodeRateAnomalyAP
wlsxNodeRateAnomalySta
wlsxNSignatureMatch
wlsxNSignatureMatchAirjack
wlsxNSignatureMatchAsleap
wlsxNSignatureMatchDeauthBcast
wlsxNSignatureMatchDisassocBcast
wlsxNSignatureMatchNetstumbler
wlsxNSignatureMatchNullProbeResp
wlsxNSignatureMatchWellenreiter
wlsxNStaUnAssociatedFromUnsecureAP
wlsxNUserAuthenticationFailed
wlsxNUserEntryAuthenticated
wlsxOmertaAttack
wlsxOverflowEAPOLKeyDetected
wlsxOverflowIEDetected
wlsxPowerSaveDosAttack
wlsxRepeatWEPIVViolation
wlsxReservedChannelViolation
wlsxRTSRateAnomaly
wlsxSequenceNumberAnomalyAP
wlsxSequenceNumberAnomalySta
wlsxSignalAnomaly
wlsxSignAPAirjack
wlsxSignAPAsleap
wlsxSignAPDeauthBcast
wlsxSignAPNetstumbler
wlsxSignAPNullProbeResp
wlsxSignatureMatchAP
wlsxSignatureMatchSta
wlsxSignStaAirjack
wlsxSignStaAsleap
wlsxSignStaDeauthBcast
wlsxSignStaNetstumbler
wlsxSignStaNullProbeResp
wlsxStaAssociatedToUnsecureAP
wlsxStalmpersonation
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wlsxStaPolicyViolation
wlsxStaRepeatWEPIVViolation
wlsxStaUnAssociatedFromUnsecureAP
wlsxStaWeakWEPIVViolation
wlsxTKIPReplayAttack
wlsxUserEntryAttributesChanged
wlsxValidClientMisassociation
wlsxValidClientNotUsingEncryption
wlsxValidSSIDViolation
wlsxWeakWEPIVViolation
wlsxWEPMisconfiguration
wlsxWindowsBridgeDetected
wlsxWindowsBridgeDetectedAP
wlsxWindowsBridgeDetectedSta
wlsxWirelessBridge

wlsxWirelessHostedNetworkContainment

wlsxWirelessHostedNetworkDetected

You will need to issue the write mem command.
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Appendix B
AirWave Data Acquisition Methods

The tables below describe the different methods through which AirWave acquires data from Aruba devices on the network.
The tables use the following symbols:

e € Initiated by AirWave
e = Initiated by Controller, Switch, or Instant Virtual Controller
o A Initiated by AirWave to a separate device

Table 5: Data Flow between Controllers and AirWave

Data Type SNMP | Traps | SSH | AMON ' PAPI Syslog | HTTPS | ICMP | NMAP  FTP/TFTP DNS Notes

802.11 Counters €«

AP Up/Down €« >

Status

ARM Events >

Channel Utilization >

Client Hostname N

Client Match >

Events

Client Monitoring € > If Prefer AMON enabled it's done

by AMON. Requires ArubaOS 6.3
or later and AirWave 7.7.7 or later.

Configuration €

Audit

Configuration €

Push

Controller € €

Up/Down Status




Table 5: Data Flow between Controllers and AirWave (Continued)

Data Type SNMP | Traps | SSH | AMON ' PAPI | Syslog | HTTPS | ICMP | NMAP  FTP/TFTP DNS Notes

Device L 3

CPU/Memory

Enabling of WMS €«

Offload

Exec Ul > When AMON is used for client
monitoring, AirWave uses this at
startup time to get current user
status.

Firewall Stats >

Firmware Images N €« Images are sent to controller over
FTP/TFTP. They can be transferred
to AirWave via HTTPS from a user
or from
https://images.arubanetworks.com

IDS Events >

Interface €

Monitoring

Lync/UCC/Voice > Available in AirWave 8.0 and later.

Neighbor Clients € >

Network €«

Derivations

RADIUS Auth >

Issues

RAPIDS €

RF Capacity >

RF Health >




Table 5: Data Flow between Controllers and AirWave (Continued)

Data Type SNMP | Traps | SSH | AMON ' PAPI | Syslog | HTTPS | ICMP | NMAP  FTP/TFTP DNS Notes

Rogue AP OS )

Rogue € € If WMS Offload enabled, AirWave
Classification updates rogue classifications on a

controller using PAPI; otherwise
it's done with SNMP.

Rogue Clients €
Syslog >
VisualRF € > VisualRF's client data comes from
AirWave, which gets its data from
SNMP + AMON.
Table 6: Data Flow between Instant Devices and AirWave
Data Type SNMP | Traps  SSH | AMON | PAPI Syslog | HTTPS @ ICMP | NMAP FTP/TFTP DNS Notes
All Monitoring Data > VC sends data to AirWave
every minute inan HTTP
POST.
Configuration > When AirWave needs to send
Commands data to a VC, itsends itin the

HTTPS response.

Diagnostic >
Commands
Firmware Images >

Table 7: Data Flow between MAS and AirWave

Data Type SNMP  Traps | SSH | AMON  PAPI Syslog HTTPS ICMP | NMAP FTP/TFTP | DNS  Notes

Configuration €




Table 7: Data Flow between MAS and AirWave (Continued)

Data Type SNMP | Traps| SSH | AMON | PAPI | Syslog HTTPS ICMP | NMAP FTP/TFTP | DNS  Notes

Firmware Images €«

Monitoring Data €«

Syslog >

Traps >

Up/Down Status €« €

Zero-Touch € >
Provisioning




Appendix C
WMS Offload Details

WMS Offload instructs the master controller to stop correlating ARM, WIPS, and WIDS state information among
its local controllers because AirWave will assume this responsibility. Figure 28 depicts how AirWave
communicates state information with local controllers.

Figure 28: ARM/WIPS/WIDS Classification Message Workflow

AirlWave Server .

Master AN
Controllers f_ ClassityAasRogue 2
/. er?l// >
4 @“‘\u, :
&5’ / Master 2
7€
Local
Controlfers . < " <& <
Local 1-1 Local 1-3 Local 21 Local 2-2 Local 2-3
AP < S OOS S < < S
AP1-2:2 AP 1.31
| ~] ]
Clients & & = & € = 2
Rogues
Rogue A Rogue B

State Correlation Process

1. AP-1-3-1 hears rogue device A.

2. Local controller 1-3 evaluates devices and does initial classification and sends a classification request to
AirWave.

3. AirWave receives message and reclassifies the device if necessary and reflects this within the Airwave WebUI
and via SNMP traps, if configured.

4. AirWave sends a classification message back to all local controllers managed by master controller 1, (1-1, 1-2,
and 1-3).

5. AirWave sends a classification message back to all additional local controllers managed by the AirWave server.
In this example all local controllers under master controller 2, (2-1, 2-2, and 2-3) would receive the
classification messages.

6. If an administrative AirWave user manually overrides the classification, then Airwave will send a re-
classification message to all applicable local controllers.

7. AirWave periodically polls each local controller's MIB to ensure state parity with the AirWave database. If the
local controller's device state does not comply with the AirWave database, AirWave will send a re-classification
message to bring it back into compliance.

HOTE

The Rogue Detail page includes a BSSID table for each rogue that displays the desired classification and the
classification on the device.
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AirWave offers the following benefits as a master device state manager:
Ability to correlate state among multiple master controllers. This will reduce delays in containing a rogue
device or authorizing a valid device when devices roam across a large campus.

Ability to correlate state of third party access points with ARM. This will ensure that Aruba infrastructure inter-
operates more efficiently in a mixed infrastructure environment.

Ability to better classify devices based on AirWave wire-line information not currently available in ArubaOS.
AirWave provides a near real-time event notification and classification of new devices entering air space.
RAPIDS gains additional wire-line discovery data from Aruba controllers.
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Appendix D
Increasing Location Accuracy

This appendix describes the impact that band steering can have on location accuracy. It also explains how RTLS
can be used to increase location accuracy.

Understand Band Steering's Impact on Location

Band steering can negatively impact location accuracy when testing in a highly mobile environment. The biggest
hurdles to overcome are scanning times in 5 GHz frequency.

Table 8: Location accuracy impact

Operating Total Scanning Scanning Total Time One

Frequency Channels Frequency Time Pass

2.4 GHz 11 (US) 10 seconds 110 121.21 seconds
milliseconds

5 GHz 24 (US) 10 seconds 110 242.64 seconds
milliseconds

Leveraging RTLS to Increase Accuracy

This section provides instructions for integrating the AirwWave and Aruba WLAN infrastructure with Aruba's RTLS
feed to more accurately locate wireless clients and Wi-Fi Tags.

Prerequisites

You will need the following information to monitor and manage your Aruba infrastructure.
o Ensure that the AirWave server is already monitoring Aruba infrastructure.

e Ensure that the WMS Offload process is complete.

o Ensure that the firewall configuration for port 5050 (default port) supports bidirectional UDP communication
between the AirWave server's IP address and each access point's IP address.
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Deployment Topology
Figure 29: Typical Client Location
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Figure 30: Typical Tag Deployment
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Enable RTLS Service on the AirWave Server

1. Navigate to AMP Setup > General and locate the Additional AMP Services section.
2. Select Yes for the Enable RTLS Collector option (see Figure 31 below).

3. Anew section will automatically appear with the following settings:

RTLS Port—The match controller default is 5050.
RTLS Username—This must match the SNMPv3 MMS user name configured on the controller.

RTLS Password—This must match the SNMPv3 MMS password configured on the controller.

4. Click Save.
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Figure 31: RTLS Fields in AMP Setup> General> Additional AMP Services

Additional AMP Services

Enable FTP server:

required to manage Aruba AirMesh & Cisco 4800 APs; optional for firmware upgrades on

supported devices.

Enable RTLS collector:
Aruba only

Use Embedded Mail Server:

Mail Relay Server: optional

Process user roaming traps from Cisco WLC:

Enable AMON Data Collection:
Enable Clarity Data Collection:

Requires ADS version 6.4.3 and above

Enable AppRF Data Collection:

AppRF Storage Allocated (GIB):
Greater than or equal to 2 GIB

Enable UCC Data Collection:

Requires ADS version 6.4 and abowve

Enable UCC Calls Stitching (Heuristics):
Prefer AMON vs SNMP Polling:
Enable Syslog and SNMP Trap Collection:

Require S5H host key verification:

Enable RTLS on the Controller

@ Yes ©

Mo

) Yes @ No

@ Yes () No

Send Test Email

@ Yes () No

@ Yes O
@ Yes ©

@ Yes ©

@ Yes O
@ Yes O

@ Yes O

NO

Mo

Mo

No

No

No

@ Yes () No

) Yes @ No

RTLS can only be enabled on the master controller and it will automatically be propagated to all local

controllers.

SSH into master controller, enter enable mode, and issue the following commands:

(Controller-Name) # configure terminal
Enter Configuration commands, one per line. End with CNTL/Z

(Controller-Name) (config) # ap system-profile <Thin-AP-Profile-Name>

(Controller-Name) (AP system profile default)
5050 key <Controller-SNMPv3-MMS-Password>

(Controller-Name) (AP system profile default)

To validate exit configuration mode:

# rtls-server ip-addr <IP of AirWave Server> port

# write mem

(Controller-Name) # show ap monitor debug status ip-addr <AP-IP-Address>

RTLS configuration

MMS 10.51.2.45 5070 120
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Aeroscout N/A N/A N/A
RTLS 10.51.2.45 5050 60 *

Troubleshooting RTLS
You can use either the WebUI or CLI to ensure the RTLS service is running on your AirWave server.,

Using the WebUI to See Status

1. Inthe AirWave WebUI, navigate to the System > Status page.
2. Scroll down through the Services list to locate the RTLS service, as shown below.

Figure 32: RTLS System Status

SERVICE & STATUS LOG

Report Runner Ok arflegfamp_report_runner
Rogue Filter oK arflogfrogue_filter
RRD Write Cache (8] 4 b

| RTLS Collector oK war(logfris |
Sate Migration Parallel Waorker Disabled ar/log/migration_worker
SMNMP Enzbler Ol arflogfsnmp_snabler
SHMP Fetcher oK arflogfsnmp_fetcher
SMMP W2 Fetcher Ol arflogfsnmp_v2_fetcher

Wi-Fi Tag Setup Guidelines

e Ensure that the tags can be heard by at least three access points from any given location. The recommended
value is four APs.

o Ensure that the tags chirp on all regulatory channels.
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